Desktop Video Conferences

Ivana.Pezelj@st.CARNet.hr
Albert.Novak@pu.CARNet.hr

Objectives

- Define basic videoconferencing terms, requirements and usage
- Distinguish between different technologies
- Demonstrate DVC Tools
- Look from user perspective
Outline

- Videoconferencing
- Desktop videoconference
- Videoconferencing tools
- Desktop videoconferencing in CARNet
- Conclusions
- Discussion

Related terms

- Video teleconference
- Videoconference
- Desk Top Videoconferencing
- DVC
- Desktop Video Conferencing
- Desktop Videoconferencing
- Video telephony
- Multimedia teleconference
- Network multimedia
**Teleconference**

- "The live exchange of information among persons and machines remote from one another but linked by a telecommunications system. The telecommunications system may support the teleconference by providing audio, video, and data services by one or more means, such as telephone, telegraph, teletype, radio, and television."

- "A conference held among people in different locations by means of telecommunications equipment."

  http://www.its.bldrdoc.gov/fs-1037/dir-039/_5790.htm

  Institute for Telecommunication Science; Boulder Colorado

---

**Teleconferencing**

- "The holding of a conference among people remote from one another by means of telecommunication devices (as telephones or computer terminals)"

  Webster dictionary

- "A conference held among people in different locations by means of telecommunications equipment, such as closed-circuit television"

  www.dictionary.com
Video teleconference

"A teleconference that includes video communications."
"Pertaining to a two-way electronic communications system that permits two or more persons in different locations to engage in the equivalent of face-to-face audio and video communications."

http://www.its.bldrdoc.gov/fs-1037/dir-039/5790.htm
Institute for Telecommunication Science; Boulder Colorado

Videoconferencing

"Holding of a conference among people at remote locations by means of transmitted audio and video signals"

Webster dictionary

"A teleconference using video technology, such as closed-circuit television"

www.dictionary.com
Common elements in definitions

- Two-way communication
- Real-time
- Audio, video
- Interactivity
- Computer network
  - Audio, video and data

Similar, but different

- Room videoconference
- Desktop videoconference
- Streaming
**Room videoconference**

- Performed for more participants (more than 3)
- TV quality/ lower than TV quality
- Room is important (light, acoustics)
- Distant lectures

- Scenario
- Chair-(wo)man
- Usually combines application-sharing from DVC

**Desktop videoconference**

- Up to 2 participants per site
- Video telephony
- Usually IP based

- Applications sharing
- Meetings
- Collaboration (project teams)
DVC requirements

- PC with:
  - sound card
  - microphone
  - headphone or speaker
  - camera:
    - regular camcorder with a video capture device
    - or
    - digital video camera (no need for video capture device)
  - access to the Internet
  - appropriate software

Streaming

- One-way transmission of audio and video
- Playing sound or video in real time as it is downloaded over the Internet as opposed to storing it in a local file first
- Broadcast transmission
- Transmission quality depends on the available bandwidth
- Requirements:
  - sender - coder (server)
  - receiver - appropriate software (plug-in)
Room vs. desktop videoconference

**Similarities**
- Audio and video transfer in real time
- Equipment used at sender side

**Differences**
- Number of participants
- Technology can differ
- Room videoconference requires better image quality

Videoconference vs. Streaming

**Similarities**
- Audio and video transfer in real time
- Use of computer network

**Differences**
- Two-way (VC) vs. one-way (S)
- Interactivity (VC)
- Equipment at the sender side
Room-, DVC-, Streaming Usage

- Distance lectures: R, S
- Meetings: D (1-1), R
- Team work: D, R
- Presentations: R, D, S

Related definitions and terms

- **Bandwidth**
  - amount of data that can be transmitted in a second
  - expressed in bits per second (bps, Kbps, Mbps, Gbps)
- **Frame Rate**
  - number of still images that are displayed every second
Multimedia Bandwidth Requirements

Audio and video adaptation for computer network

Sender

digitalization (de/compression)
packetization

Receiver
Desktop videoconference

Agenda

- Point-to-point vs. Multipoint
- (De)centralized model
- Transmission types - *cast
- Standards
  - H.323 series and components, T.120
- DVC Tools

We will continue with ...

- VC types
  - Point-to-point, multipoint, centralized and decentralized
- Transmission type
  - Unicast, broadcast and multicast
- H.323
  - Standard, components and terms
- Some of VC tools
Desktop videoconference

- **Point-to-point**
  - two participating sites
- **Multipoint**
  - three or more participants
  - centralized model
  - decentralized model

**Centralized model**

- all of the audio and video is transmitted to the central point (MCU) that mixes the multiple audio streams, select the corresponding video stream, and re-transmits the results to all of the participants.
Decentralized model

- the multipoint functions distributed among the participating terminals

Transmission type

- **Unicast**
  - piece of information is sent from one point to another point

- **Broadcast**
  - piece of information is sent from one point to all other points

- **Multicast**
  - piece of information is sent from one or more points to a set of other points
What is H.323?

- Cornerstone technology for the transmission of real-time audio, video and data communications over packet based networks.

H.32x family

- H.324 over Switched Circuit Network (SCN)
- H.320 over Integrated Services Digital Networks (ISDN)
- H.310 over Broadband Integrated Services Digital Networks (B-ISDN)
- H.321 over Asynchronous Transfer Mode (ATM)
- H.322 over LAN that provide guaranteed QoS
**H.323 and relevant references**

- audio CODEC (G.711, G.722, G.723.1, G.728, G.729)
- video CODEC (H.261, H.263)
- H.225 registrations, admission and status (RAS)
- H.225 call signaling
- H.245 control signaling
- real-time transfer protocol (RTP)
- real-time control protocol (RTCP)

**H.323 components**

- Terminals
- Gateways
- Gatekeepers
- Multipoint control units (MCU)
Terminal

H.323 terminal must support the following:

- H.245 for exchanging terminal capabilities and creation of media channels
- H.225 for call signaling and call setup
- RAS for registrations and admission control with a gatekeeper
- RTP/RTCP for sequencing audio and video packets
- Audio CODEC (G.711)

Optional component for H.323 terminals:

- Video CODEC
- T.120 for data exchange
- MCU capabilities (if we use decentralized model of multipoint videoconferencing)
The Gateway component provides connectivity between H.323 terminals and other H.3xx terminals operating on their respective networks. Gateway translates protocols for call setup and release, convert media formats between different networks, and transfer information between H.323 and non-H.323 networks.
Gatekeeper

- Gatekeeper provides call-control services for H.323 endpoints, such as address translation and bandwidth management.
- Gatekeeper is optional, but if present in the network, terminals and gateways must use his services.

Gatekeeper Mandatory Functions

- Address Translation
- Admission Control
  - control the admission of the endpoints using RAS messages
- Bandwidth control
  - control bandwidth using RAS messages;
- Zone Management
  - H.323 zone is a collection of all terminals, gateways and MCUs managed by a single gatekeeper.
Gatekeeper Optional Functions

- **Call-control signaling**
  - The gatekeeper can route call-signaling messages between H.323 endpoint or allow the endpoints to send H.225 call-signaling directly to each other

- **Call authorization**
  - The gatekeeper may accept or reject the call (reasons for rejection may include access-based or time-based restrictions)

- **Call management**
  - Maintain information about all active H.323 calls

---

**MCU – Multipoint Control Unit**

- **Provides support for conferences of three or more H.323 terminals**
- **All terminals in the conference establish connection with the MCU**
- **Manages conferences resources, negotiates between terminals to determine audio or video CODEC**
MCU – Multipoint Control Unit

The MCU consists of two parts:

- Multipoint Controller (MC) – mandatory
  - The MC provides capability for call control to negotiate with all terminal to achieve common levels of communication
- Multipoint Processors (MP) – optionally
  - The MP allows mixing, switching or other processing of media streams under control of the MCU

Data Collaboration (T.120)

- T.120 is a family of recommendation that define the protocols for data collaboration
- T.120 is network independent (T.120 works over IP, ISDN, ATM or even analog telephone network)
- T.120 recommendations are arranged in a layered hierarchy such that each layer leverages the layers above it to define protocols and services
T.120 recommendations

- T.121 – general template that provides guidance for developing T.120 application protocols
- T.122/125 – multipoint communication service protocols
- T.123 – transport protocol stack
- T.124 – generic conference control
- T.126 – still image and annotation protocol
- T.127 – binary file transfer protocol
- T.128 – application sharing protocol

T.120 protocol stack

<table>
<thead>
<tr>
<th>Application user interface</th>
</tr>
</thead>
<tbody>
<tr>
<td>ITU-T defined applications T.126 (image transfer), T.127 (file transfer), etc</td>
</tr>
<tr>
<td>T.121 Generic Application Template (GAT)</td>
</tr>
<tr>
<td>T.124 Generic conference Control (GCC)</td>
</tr>
<tr>
<td>T.122-T.125 Multipoint Communication Services (MCS)</td>
</tr>
<tr>
<td>T.123 Network Specific Transport Protocol (IP, ATM, Ethernet, etc.)</td>
</tr>
</tbody>
</table>
DVC Tools

- **iVisit**
  - Audio/Video data flow directly from peer to peer
  - Robust video encoding adapts to a wide range of network conditions
  - High quality audio using Lucent Technologies Elemedia (tm) group codecs
  - Win 95/98/NT, Mac
  - http://www.ivisit.com/

- **Internet Phone**
  - PC-to-PC or PC-to-phone calling
  - Whiteboard, chat, file transfer, voicemail
  - Win 95/98/NT, Mac

- **CU-SeeMe**
  - Multiparty conferences of up to 12 people
  - Can be used with a 28.8K or higher modem connection
  - Windows 3.*/95/98/NT, Macintosh and Power Macintosh
  - http://www.wpine.com/

- **Netmeeting**
- **Sametime**
- **Phone Dialer (Win 2000)**
Multicast (MBONE) Tools

- Robust Audio Tool (RAT)
  - The Robust Audio Tool (RAT) is an open-source audio conferencing and streaming application that allows users to participate in audio conferences over the internet. These can be between two participants directly, or between a group of participants on a common multicast group.

- Videoconferencing Tool (VIC)
  - To make use of the conferencing capabilities, your system must support IP Multicast, and ideally, your network should be connected to the IP Multicast Backbone (MBone).

- Session Directory (SDR)
  - SDR is a session directory tool designed to allow the advertisement and joining of multicast conferences on the Mbone.

OpenH323 MCU and Gatekeeper

- OpenH323 is a project committed to the collaborative development of an Open Source H.323 protocol stack that is available for use by both private and commercial users.

- OpenH323 is needed because commercial implementations of the H.323 protocol stack are expensive to license and distribute. They also contain proprietary IP that cannot be used or distributed without the permission of the owners, and they are not Open Source.
Microsoft NetMeeting

Agenda
- Features
- Advantages
- Disadvantages
- Settings
- Collaboration
Microsoft NetMeeting Features

* Groupware
* Easy to use
* Wide-spread
* Free
* Can send audio and video
* For Windows (95/98/Me/2000)
* With Windows 2000 comes preinstalled

http://www.microsoft.com/netmeeting

NetMeeting - Advantages

* Source code is public, stable, small and effective
* Allows collaboration with other users
* Has a variety of codecs to fit different types of connections
* Can find people using ILS servers as well as IP addresses
* Several people can share chat screen
NetMeeting - Disadvantages

- Video quality depends on connection type
- Limited video conferencing capability
- Only one person can be listened to at a time
- Can send video and audio simultaneously, while other person sends audio only
- Noticeable delay in audio
- Needs a server to coordinate the various video streams in order to get several people together

Features in letters and numbers

- Communication only over TCP/IP
- Chat: N to N
- Whiteboard: N to N
- File transfer: N to N
- Audio/Video: 1 to 1
- Lists only 15 ILS servers
Netmeeting User Interface

- Menu
- Call buttons
- Address
- Video image
- Audio/video buttons
- Participants
- Collaboration
- Status line

User Interface - Buttons

- Inactive button
- Active button
  - yellow edge
- Currently without functions
  - gray-colored
**Status bar**

- State regarding ILS server
  - no connection
  - connection established
- Direct connection
  - no connection
  - connection established
  - secure connection established
  - do not disturb

**Calls**

- Using directory server
- Directly, using IP address
- Call button
  - or Call → New Call... (Ctrl+N)
- Connection establishment can last up to several minutes.
  - Be patient!
What is my IP address?

Help → About

Start → Run → ipconfig
    winipcfg

Network Bandwidth Settings

Tools → Options → General → Bandwidth Settings...
Audio preferences

- On-button click changes user interface
- Microphone and Speaker adjustments:
  - Mute/Unmute
  - Adjust Volume

Audio Options

- Tools → Options → Audio
  - Full duplex – enable sending and receiving sound at the same time
  - Auto-gain HW and Automatically adjust mic. volume SW adjusts microphone volume
Video Options

Tools → Options → Video

- Automatically send/receive video
- Send image size
- Video quality
- Video camera properties

Video adjustments

Tools → Video
- Send/Receive Video
- Image Window Size
Collaboration

- Additional applications allow other ways of communication than audio and video
- Not "intuitive" part of *conference* definition
- Result of all-media integration with computer network
- Includes:
  - Chat
  - Whiteboard
  - File transfer
  - Application sharing
  - Desktop sharing

Chat

- Exchange of messages between participants
- Sent message appears in Chat window at the screen of other participants
- Ctrl+T or Tools→Chat
- "Send"
Chat Options

- Configuration dialog
  - information about the sender
  - message format
  - fonts

In Chat screen: View → Options

Whiteboard

- Tools → Whiteboard or Ctrl+W

- Drawing tools
- Whiteboard
- Page selection
- Colors
**Whiteboard Icons**

- **Drawing tools**
  - selector
  - eraser
  - text
  - highlighter
  - pen
  - line
  - rectangle

- **Tools**
  - ellipse
  - zoom
  - remote pointer
  - lock contents
  - synchronize
  - select area
  - select window

---

**File Transfer**

- Uses FTP - File Transfer Protocol
File Transfer

- FTP server is not needed
- Files are sent
  - usual file transfer allows get or put
- Enhanced security during file transfer

Application Sharing

- Tools → Sharing or Ctrl+S
- Shows applications that can be shared
Application Sharing

- Select an application
- Click Share
- Checkmark on the left marks shared application

Application Un-Sharing

Unshare
  - stops sharing marked application

Unshare All
  - stops sharing all applications
**Application Sharing - Control**

- Allowing other participants to take control over shared applications:
  - Allow Control
  - Prevent Control

- Request for control:
  - Automatically accept requests
  - Do not disturb - deny all

---

**Remote Desktop Sharing**

- Can be considered as special case of Application sharing
- Suitable for troubleshooting
- Convenient for technical support
- When "on", local user has no control
- Tools
  - Remote Desktop Sharing
- Starts with Wizard
**SameTime**

- Multipoint conferencing
- Web client – multiple platform support
- Standard-based (T.120 and H.323 support)
- Web administration
- Support for whiteboard, chat and data sharing
- Collaborate, moderate and broadcast meeting
- Authentication and Access Control
- Encryption and privacy
Server system requirements

- CPU: Pentium II 300MHz (or higher)
- Operating systems: Windows 2000 Professional or Windows NT with Service Pack 5
- Memory: Windows NT: Minimum 128MB; 256MB RAM (or more) recommended
  Windows 2000: Minimum 192MB; 320MB RAM recommended
- Disk space: 300MB of free disk space. 500MB is recommended to allow space for meetings, applications, and databases
- Network Software: TCP/IP network software installed

CODECS used by Sametime 2.0

- H.263
  - Optimized for low data rates and relatively low motion. The primary goal of H.263 is to provide good quality video below 64kbps
- G.711
  - Optimized for compression of speech data that is transmitted over links with minimum speed of 64kbps
- G.723
  - Optimized for compression of speech data that is transmitted over standard telephone lines (6.3kbps)
Configuration – Audio/Video

- Audio bit-rate
- Video bit-rate
- Jitter buffer
- Audio frames per packet
- Microphone mode and number of streams
- Switching
- Usage limits and denied entry
Create New Meeting

Attend a Meeting
Participating in the Meeting

Sametime Connect

- Awareness
- Instant Messaging
- Instant Chat
- Instant Audio meeting
- Instant Video meeting
- Instant sharing meeting
- Instant collaboration meeting
Windows 2000 Phone Dialer

- Support for IP telephony
- Support for H.323 conferencing
- Support for multipoint multicast conferencing
- Different from old Phone Dialer in Windows 95/98/Me/NT
- Use ILS for user-to-IP resolution

Microsoft ILS

- ILS - Internet Locator Service
  - Provide user-to-IP address resolution
- Support for multipoint multicast conferences
- Use Lightweight directory Access Protocol (LDAP)
How and when to use DVC

- Meetings
- Education
- Presentations
- Fun - no rules for usage!

DVC for meetings

- **Benefits**
  - no need for traveling
  - cheaper
  - time saving
- **Disadvantages**
  - no closer contact
  - first meetings - with unknown or less known participants
DVC in education

Benefits
- no need for traveling
- cheaper
- time saving

Disadvantages
- not suitable for all types of lectures
- professor/student relationship

Addition, not a substitute

DVC for presentations

Use of DVC tools for:
- application sharing
- temporary videoconferencing connection

As an addition to other types of videoconference
- e.g. - in combination with room videoconferencing
Videoconferencing in CARNet

- Conferencing
- Education
- Meetings
- Medicine
- Project team work
- Room VC
- Desktop

... as Combine

**Conferencing**
1. Room-, ATM based videoconference
2. Application sharing using Netmeeting
3. Streaming broadcast using Real Video

**Example:**
- CARNet Users Conference (1999, 2000) (1, 2, 3)
- Exhibition of University of Split (2000) (3)
- Telemedicine (1998) (1, 2)
**Education**

1. Room-, ATM based videoconference
2. Application sharing using Netmeeting

**Example:**
- Joined lecture for medical students from Medical Schools from four Croatian Universities

---

**Meetings**

1. Room-, ATM based videoconference
2. Application sharing using Netmeeting

**Example:**
- CARNet Users Council

1. DVC and application sharing using Netmeeting
   **Example:**
   - Internal meetings
Common CARNet scenario

DVC Etiquette

* "Talking stick"
* Do not interrupt others talking during the session
* Talk so to be heard at the other side
* "Chair person" (moderator)
* Look directly to the camera - eye contact
* Choose clothing carefully
  * try to avoid black, white or very extreme patterns
Conclusion

- Voice, video and data integration using same media and simple, easy-to-use common user interface
- Common PC configuration - multimedia enabled
- Different technologies for different scenarios
- DVC is applicable for different occasions
- Different tools exist - use the one you know/like

References

- "Understanding Networked Multimedia", François Fluckiger
- "Windows Netmeeting" (B400), Denis Stančer, SRCE/CARNet end-user course
- DVC Tools overview
  - http://myhome.hananet.net/~soonjp/vidconf.html
- Videoconference Guide
  - http://www.coe.missouri.edu/~cjb/video/links.htm
  - http://www.openh323.org
  - http://www.itu.com/
Discussion

- How useful is it for my environment?
  - How much does it cost to implement
  - How much does it cost to use
- How costly it is?
  - money, time, ...
- How can videoconference challenge face-to-face communication?
- What do I need now?
- Now or never?

Questions & Comments?

Albert.Novak@pu.CARNet.hr
Ivana.Pezelj@st.CARNet.hr